Newsletter quests not registering as complete


    In the Foundation, I have credit for having viewed 3 newsletters, but I've been receiving newsletters and reading them for about a year now.

    I went to the most recent newsletter and even clicked on a link in it to read the information on the website, but got no credit for it. I tried several of the most recent newsletters, but got no credit for any of them. Finally, I tried a really old one, but still no luck.

    Is anyone else having this problem, or does anyone know a workaround?



    It sometimes takes a while for website to register it.
    I waited 3 hours in most recent letter.
    Sometimes its instant.


    Hm. It's been about 20 hours or so, I think, and no luck yet. Credit for the same 3 as before.


    Also make sure you check all links in the mail, not just "check your progress". It may help website to recognize you better.

    Personally, I always make sure I am logged in both to my mail and to my Fractured account on web. Then i make sure cookies aren't blocked on those sites. And then I open mail, read all the links, and in the end I "check my progress".

    It wasn't always instant but i got points eventually. 🙂

Log in to reply

Copyright © 2022 Dynamight Studios Srl | Fractured